Oct 31

Back in January 2011 i wrote about the NAV Launcher, a project based on the Navision Starter v1.2 orignally created by Sergey Gazizyanov back in 2006. Well, i realized that i never put a download link on the site.

Attached in this post is the installer for the .NET project. It requires, as far as i remember .NET framework version 2.

Just run the setup and it should install and also register the .fdb extension, for you that still use the native databases in local installs.

When running the NAV Launcher the first time you need to assign the path for the correct versions of the executables. After that it should work automagically! I have not tested in other systems than my own, so there might be some compatability issues, please let me know about any.

How it works? For SQL databases it basically just does this query to find the current databaseversion:

In native versions it reads directly in the .fdb file, at the position 0x2005 and from that determines the correct version.

If you would like to do enhancements, like automatic discovery of clients installed, please email for collaboration info at gotcal@navtilus.com.

[dm]13[/dm]




5 Responses to “NAV Launcher – download”

  1. […] Bron : Got C/AL? Lees meer… […]

  2. You can edit the settings.ini file to set your default credentials for database login, and also the list of your default servers.

  3. Pete says:

    Great stuff, thanks for publishing this Soren.

    If you are able to share source code, I would like to experiment with something different: automatic selection of SQL server in a mirrored environment.

  4. Ron Saritzky says:

    Soren,

    We had a situation where we had a test database and a development database that were opened with 2 different versions of the NAV client – the Development database was opened with NAV2009R2 executable version 6.00.32441 and the test database was using 6.00.32012. As far as I know (please correct me if I’m wrong), the NAV client will allow you to go back and forth between these 2 executables on the same database – the problem occurs when you try to export objects from v32441 and import them into the db opened with 32012.

    My question is do you believe that NavLauncher will be able to determine the right version of the executable in this situation? Or is this part of your “executable discovery” enhancement project?

    Thanks
    Ron Saritzky (friend/colleague of Henrik Helgesen)

  5. Tarek says:

    Hello Soren,

    Does NAV Launcher support NAV 2013 too ?

    BR
    / Tarek

Leave a Reply

preload preload preload
pornpants.com pornofri.com kilporn.com